Windows 7 keyboard and administrator issues


Well-Known Member
Hi there,

My mom has a Windows 7 puter (I think it's a Dell). A few months ago while I was down there to help her, as I was typing I accidentally pressed a couple of buttons and it caused the keyboard to stop working properly. I have no idea what I pressed to cause the issue. I tried rebooting the PC, doing a system restore, scanning for errors viruses...all came up clean with no issues.
Ever since then, mom's puter now will not let her log in as Administrator. She must automatically switch to another user first. Even then, the keyboard does not work properly. The only solution I came up with is to enable the on-screen keyboard, which (weirdly) then causes her regular keyboard to work properly. Then I turn off the on-screen keyboard.

I'll skip the part where my mom has reminded me many times since then that I caused her to have these problems. :violin

Any solutions other than replacing the keyboard? I just ordered her a new one, even though she doesn't think that is the problem. We'll see.


My soul waits for the Lord, and in His Word I hope
If the problem is that the keyboard works, but is given different letters than you would expect, maybe you accidently switched the language. You can check it in the settings.

Tall Timbers

Imperfect but forgiven
I've faced a lot of technology issues, but never one like you've described. Please share with us if a new keyboard resolves the issue. I would just make a guess, based on your description of what happened, that it is a system software issue that would need correcting and it is possible that when you hit that fateful keyboard key combination that a code error may also have been introduced.

Here's some links that may or may not be useful to you:
Last edited:


Staff member
If it is a software or setting issue, perhaps doing a "system restore" back to a point before the "accident" might help resolve it?

The worse that could happen is that you have to re-install a system update or something. :idunno


Well-Known Member
I tried a system restore and it didn't resolve the problem.
I'm just waiting for the new keyboard to arrive at my mom's home. I'm 5 hours away from her and have no car, so getting there is a problem. She's out in the country, at least an hour from any decent bus or train station.


Borg # 8675309
I'm thinking you did one of these two:

Left Alt+Shift - Switch the input language when multiple input languages are enabled

Ctrl+Shift - Switch the keyboard layout when multiple keyboard layouts are enabled

You could try pressing those combinations again (one at a time of course) to see if it switches back.


Borg # 8675309
Also, if you press the shift key 5 times in a row it turns on "sticky keys" which could cause problems. It would have popped up a window notifying you of it though and it leaves an icon on the taskbar. You press shift 5 times again to turn it off.